Help → Cannot connect to POPfile

Cannot connect to POPfile

Firefox can’t establish a connection to the server at

That's the response I get when I try to retrieve my email.

I have been using POPfile and Eudora on a Windows XP platform for years, with Earthlink as my ISP. It has worked wonderfully well except for a glitch when I had to repair the OS installation after setting up a dual boot with Windows 10. That was in March, and after getting things running again, everything worked even better than it had previously.

That is, until 9:00 AM on June 7. That was when the last email was successfully retrieved from the Earthlink server. The problem has boiled down to an inability to connect to the POPfile server.

I can connect to the POPfile User Interface using the icon in the system tray.

And I can connect by typing into a Firefox address bar (but it’s a bare UI, with no message data or messages, but my 5 buckets are defined).

But I cannot connect by typing into the Firefox address bar.

For what I am certain is the same reason, I cannot retrieve my emails, although I can send email OK.

I am unaware of anything that could have happened on or around June 7 to trigger this change in operation. I tried changing to in my Eudora configuration files, but that has not helped.

I have been suspecting a virus, but I can't detect any.

Here is a log, level 1, output from a Eudora - Check Mail command. The Firefox page showed “Firefox can’t establish a connection to the server at”

2018/6/15 10:56:08 1904: POPFile stopped
2018/6/15 10:56:08 1904: ---------------
2018/6/15 10:56:19 2992: -----------------------
2018/6/15 10:56:19 2992: POPFile v1.1.3 starting
2018/6/15 10:56:19 2992: bayes: 811: Attempting to connect to dbi:SQLite:dbname=C:\DOCUME~1\Bob\APPLIC~1\POPFile/popfile.db (1)
2018/6/15 10:56:19 2992: bayes: 912: Using SQLite library version 3.7.2
2018/6/15 10:56:19 2992: bayes: 512: Performing tweak 1 to 1
2018/6/15 10:56:20 2992: bayes: 2231: get_session_key returning key oZ5mvNhLJ7iESKYkM9m for user XXXXXX
2018/6/15 10:56:20 2992: html: 66: Trying to open listening socket on port 8080.
2018/6/15 10:56:20 2992: pop3: 132: Opening listening socket on port 110.
2018/6/15 10:56:20 2992: bayes: 2128: release_session_key releasing key oZ5mvNhLJ7iESKYkM9m for user XXXXXX
2018/6/15 10:57:11 2992: bayes: 2231: get_session_key returning key 5NgnFHI1AZo461fNy7 for user XXXXXX

  • Message #2215

    Here is the output of Message Capture. It appears that something is missing from Maybe a re-install is called for?

    POPFile Message Capture Utility v0.2.0

    Using 'popfileif.exe' to run POPFile

    (report started 16-Jun-2018 @ 07:33:10)

    POPFile Engine loading


    {core: windows}
    {core: config history logger mq}
    {classifier: bayes wordmangle}
    {interface: html}
    {proxy: pop3}

    POPFile Engine v1.1.3 starting


    {core: config history logger mq windows}
    {classifier: bayes wordmangle}
    {interface: html}
    {proxy: pop3

    A copy of POPFile appears to be running.

    Attempting to signal the previous copy.
    Waiting 10 seconds for a reply.

    A copy of POPFile is running.
    It has signaled that it is alive with process ID: 2596

    Failed to start while starting the config module at C:\PROGRA~1\POPFile/POPFile/ line 748.




    POPFile Engine v1.1.3 stopping


    {classifier: bayesCan't call method "finish" without a package or object reference at C:\PROGRA~1\POPFile/Classifier/ line 1273.

    Status code: 9

    (report finished 16-Jun-2018 @ 07:33:22)

  • Message #2216


    It took me most of a week, but I have my Eudora / POPfile email running smoothly. For those who are interested, here's what I found, and what I did.

    Back in early March, I installed Windows 10 on my desktop in a dual-boot setup with Windows XP. I messed something up on the XP side that eventually required a complete repair of the OS. After that, everything was fine until 9:00 AM on June 7. That was when my last email was delivered. From then on, I could send email, but I could not download it from my ISP. Any attempt to "Check (Get) Mail" would result in a Firefox window displaying the error "Firefox can’t establish a connection to the server at"

    If I typed into the address field of Firefox, I would get the same error, but if I added the port number,, it would bring up the POPfile User Interface (UI). It was an empty UI, with no messages. A lot of research, digging, and testing came up empty. One thing I tried was to change all of the occurrences of within my Eudora configuration to Still no luck; same error from Firefox every time I tried to retrieve mail.

    Sifting through Google results and POPfile forum entries yielded some new thoughts, but nothing came from them. However, I did discover some irregularities in my data. Prior to the dual-boot of Windows 10, I kept my OS, my programs, and my personal data all in different disk partitions. Personal data included Eudora and POPfile installations, which were still active from years ago.

    But Win 10 changed my partition letters when it installed, and then put itself in a totally different partition. I got that straightened out so that email was working fine, but I didn't realize what a mess I had. Hey, it was working. That is, until June 7. I still don't know what happened that disabled my ability to get email.

    As my trouble shooting quickly ran out of bullets, I decided to try the old "reinstall" solution. I did an uninstall, saving the popfile.db, and then re-installed in the default folder, which was the folder that Windows 10 had installed itself. Nothing changed, I still couldn't retrieve mail.

    After doing more "let's try this," and "let's try that," I realized I had POPfile files spread out all over the place. I had the primary installation in the partition with Win 10, the old installation was still in the partition with my programs, and there were POPfile files in the Eudora folder in my personal data partition. I was not surprised that it wasn't working.

    I cleaned everything up, deleting or uninstalling everything I could find that was associated with POPfile. I first backed up some files that I thought might be needed later. No research, just intuitive feelings that certain files might come in useful later (but it turned out that none were needed). Now that I had a clean slate, I downloaded the latest version of POPfile and installed it in the default locations, using setup.

    Now for the big test. I started Eudora, clicked on Get Mail, and lo and behold, 179 messages came flowing in. It worked perfectly, including classifying them all as [unclassified], which was to be expected since I had started with a clean database. The retrieval worked, the classification worked, the authentication worked, SSL worked, and the password worked. The only surprise was that my 4 buckets were still defined; I didn't expect them to be.

    I'm a bit bothered that I still can't connect to the UI using in a Firefox window; I have to append the 8080 port number. A bare used to work, before all this went down.

    It's too late to make a long story short, so let me sign off by saying that if my experience helps you, great. If not, well, it was fun writing it down, and it had a happy ending for me..


  • Message #2217

    I'm a bit bothered that I still can't connect to the UI using in a Firefox window; I have to append the 8080 port number.

    If you only type into Firefox then I think Firefox will attempt to connect to a webserver using port 80 as that is the default HTTP port number.

    By default the webserver POPFile creates to display the User Interface (UI) uses port 8080 which is why you need to use (or http://localhost:8080) to access POPFile's UI with Firefox.

    More than one webserver can be running at the same time on (or localhost) provided they use different port numbers. This is why the POPFile UI port number is not hard coded; if other software on your computer is already using port 8080 then POPFile must be configured to use an unused port number (this is discussed in the Connection Problems with POPFile UI page in the on-line manual).

    Glad to hear that you have got POPFile working again.