Differences

This shows you the differences between two versions of the page.

howtos:allplatformsrequireperl [2009/05/04 00:07]
xuesheng Mention ActivePerl 5.8/5.10 incompatibility
howtos:allplatformsrequireperl [2013/10/27 04:18] (current)
amatubu Added Win32::GUI and XMLRPC::Lite to required module list
Line 3: Line 3:
Regardless of the OS, you must have a working Perl installation to use the cross-platform version of POPFile. Regardless of the OS, you must have a working Perl installation to use the cross-platform version of POPFile.
-  * Windows users must have Perl 5.8.0 or above, available from [[http://www.activestate.com/Products/ActivePerl/| ActiveState]] The current Perl 5.8 release is %%ActivePerl%% 5.8.9 build 825 available from [[http://www.activestate.com/activeperl/downloads/|ActiveState downloads]] (**Note:** The Windows version of POPFile is based upon Perl 5.8. Perl 5.10 is not binary compatible with Perl 5.8. In particular, do not attempt to use extensions or PPM packages built for %%ActivePerl%% 5.8 series builds with %%ActivePerl%% 5.10 series builds and vice versa.)+  * Windows users must have Perl 5.8.0 or above, available from [[http://www.activestate.com/Products/ActivePerl/| ActiveState]] The current Perl 5.8 release is %%ActivePerl%% 5.8.9 build 826 available from [[http://www.activestate.com/activeperl/downloads/|ActiveState downloads]] (**Note:** The Windows version of POPFile is based upon Perl 5.8. Perl 5.10 is not binary compatible with Perl 5.8. In particular, do not attempt to use extensions or PPM packages built for %%ActivePerl%% 5.8 series builds with %%ActivePerl%% 5.10 series builds and vice versa.)
  * All other users must have Perl 5.6.0 or above, available from [[http://www.perl.org/get.html| Perl Org]] (Perl 5.7.3 or above, if you want Japanese/Korean language support)   * All other users must have Perl 5.6.0 or above, available from [[http://www.perl.org/get.html| Perl Org]] (Perl 5.7.3 or above, if you want Japanese/Korean language support)
Line 29: Line 29:
  - [[http://search.cpan.org/~timb/DBI/ | DBI]]   - [[http://search.cpan.org/~timb/DBI/ | DBI]]
  - [[http://search.cpan.org/~msergeant/DBD-SQLite/ | DBD::SQLite]] (if you are using the default SQLite for the backend database)   - [[http://search.cpan.org/~msergeant/DBD-SQLite/ | DBD::SQLite]] (if you are using the default SQLite for the backend database)
-    - IMPORTANT NOTE: There are two incompatible flavours of SQLite: 2.x and 3.x. POPFile 1.1.0 (or later) uses SQLite 3.x therefore it requires DBD::SQLite v1.00 or later (1.1.0 was tested using v1.13 and v1.14). POPFile 0.25.0 to 1.0.1 used SQLite 2.x and requires DBD::SQLite v0.31 which is the last version of DBD::SQLite based upon SQLite 2.x. (To use that old version, you will need to specify the full path when you install from CPAN, e.g., cpan> install M/MS/MSERGEANT/DBD-SQLite-0.31.tar.gz) [[SQLite3| More detail can be found here]]+    - IMPORTANT NOTE: There are two incompatible flavours of SQLite: 2.x and 3.x. POPFile 1.1.0 (or later) uses SQLite 3.x therefore it requires DBD::SQLite v1.00 or later (1.1.0 was tested using v1.13 and v1.14). POPFile 0.25.0 to 1.0.1 used SQLite 2.x and requires DBD::SQLite v0.31 which is the last version of DBD::SQLite based upon SQLite 2.x. (To use that old version, you will need to specify the full path when you install from CPAN, e.g., cpan> install M/MS/MSERGEANT/DBD-SQLite-0.31.tar.gz) [[:SQLite3| More detail can be found here]]
  - [[http://search.cpan.org/~msergeant/DBD-SQLite2/ | DBD::SQLite2]] (if you are using any POPFile version between 0.22.5 and 1.0.1 or upgrading to 1.1.0 (or later) from 0.22.0, 0.22.1, 0.22.2, 0.22.3, 0.22.4, 0.22.5, 1.0.0 or 1.0.1)   - [[http://search.cpan.org/~msergeant/DBD-SQLite2/ | DBD::SQLite2]] (if you are using any POPFile version between 0.22.5 and 1.0.1 or upgrading to 1.1.0 (or later) from 0.22.0, 0.22.1, 0.22.2, 0.22.3, 0.22.4, 0.22.5, 1.0.0 or 1.0.1)
  - [[http://search.cpan.org/~capttofu/DBD-mysql/ | DBD::mysql]]  (if you are using MySQL for the backend database)   - [[http://search.cpan.org/~capttofu/DBD-mysql/ | DBD::mysql]]  (if you are using MySQL for the backend database)
Line 46: Line 46:
  - [[http://search.cpan.org/~gbarr/TimeDate/ | TimeDate]]  (on Windows only)   - [[http://search.cpan.org/~gbarr/TimeDate/ | TimeDate]]  (on Windows only)
  - [[http://search.cpan.org/~mkutter/SOAP-Lite/ | SOAP::Lite]] (if you want to use XMLRPC)   - [[http://search.cpan.org/~mkutter/SOAP-Lite/ | SOAP::Lite]] (if you want to use XMLRPC)
 +  - [[http://search.cpan.org/~phred/XMLRPC-Lite/ | XMLRPC::Lite]] (if you want to use XMLRPC on Windows)
 +  - [[http://search.cpan.org/~tate/File-Glob-Windows/ | File::Glob::Windows]] (if you want Japanese language support on Windows)
 +  - [[http://search.cpan.org/~robertmay/Win32-GUI/ | Win32::GUI]] (POPFile 1.1.0 or later on Windows only (which is used for Tray icon support) )
If you want to use SSL you'll also need OpenSSL (http://www.openssl.org/). If you want to use SSL you'll also need OpenSSL (http://www.openssl.org/).
Line 62: Line 65:
<code>   perl -v</code> <code>   perl -v</code>
-===== Sample ActivePerl-5.8.4.810 (ActiveState) Win32 Basic Install =====+===== Sample ActivePerl-5.8.9.826 (ActiveState) Win32 Basic Install =====
-Install ActivePerl-5.8.4.810+Install ActivePerl-5.8.9.826
Switch to the /perl/bin directory Switch to the /perl/bin directory
Type PPM Type PPM
Line 70: Line 73:
  PPM>Install timedate   PPM>Install timedate
  PPM>Install html-template   PPM>Install html-template
-  PPM>Install dbd-sqlite2+  PPM>Install dbd-sqlite
  PPM>q</code>   PPM>q</code>
-Install Popfile 0.22.1 and adjust configuration for SQLite2. [[SQLite3| There is a detailed explanation of the SQLite2 and SQLite3 issue here]]+Install the latest version of Popfile and adjust configuration for SQLite.
You now have a functional Popfile configuration. If you plan to use additional Popfile modules or services you may have to add additional perl modules. You now have a functional Popfile configuration. If you plan to use additional Popfile modules or services you may have to add additional perl modules.
Line 90: Line 93:
<code>  perl -MCPAN -e shell <code>  perl -MCPAN -e shell
  cpan>install DBI   cpan>install DBI
-  cpan>install DBD::SQLite2+  cpan>install DBD::SQLite
  cpan>install HTML::Template   cpan>install HTML::Template
  cpan>install Date::Parse   cpan>install Date::Parse
  cpan>quit</code>   cpan>quit</code>
-Install Popfile 0.22.1 and adjust configuration for SQLite2. [[SQLite3| There is a detailed explanation of the SQLite2 and SQLite3 issue here]]+Install the latest version of Popfile and adjust configuration for SQLite2.
You now have a functional Popfile configuration. If you plan to use additional Popfile modules or services you may have to add additional perl modules. You now have a functional Popfile configuration. If you plan to use additional Popfile modules or services you may have to add additional perl modules.
 
howtos/allplatformsrequireperl.1241388461.txt.gz · Last modified: 2009/05/04 00:07 by xuesheng

Should you find anything in the documentation that is incomplete, unclear, outdated or just plain wrong, please let us know and leave a note in the Documentation Forum.

Recent changes RSS feed Donate Driven by DokuWiki
The content of this wiki is protected by the GNU Fee Documentation License