Differences

This shows you the differences between two versions of the page.

howtos:allplatformsrequireperl [2009/07/15 01:31]
amatubu Added a new module 'File::Glob::Windows'
howtos:allplatformsrequireperl [2013/10/27 04:18] (current)
amatubu Added Win32::GUI and XMLRPC::Lite to required module list
Line 3: Line 3:
Regardless of the OS, you must have a working Perl installation to use the cross-platform version of POPFile. Regardless of the OS, you must have a working Perl installation to use the cross-platform version of POPFile.
-  * Windows users must have Perl 5.8.0 or above, available from [[http://www.activestate.com/Products/ActivePerl/| ActiveState]] The current Perl 5.8 release is %%ActivePerl%% 5.8.9 build 825 available from [[http://www.activestate.com/activeperl/downloads/|ActiveState downloads]] (**Note:** The Windows version of POPFile is based upon Perl 5.8. Perl 5.10 is not binary compatible with Perl 5.8. In particular, do not attempt to use extensions or PPM packages built for %%ActivePerl%% 5.8 series builds with %%ActivePerl%% 5.10 series builds and vice versa.)+  * Windows users must have Perl 5.8.0 or above, available from [[http://www.activestate.com/Products/ActivePerl/| ActiveState]] The current Perl 5.8 release is %%ActivePerl%% 5.8.9 build 826 available from [[http://www.activestate.com/activeperl/downloads/|ActiveState downloads]] (**Note:** The Windows version of POPFile is based upon Perl 5.8. Perl 5.10 is not binary compatible with Perl 5.8. In particular, do not attempt to use extensions or PPM packages built for %%ActivePerl%% 5.8 series builds with %%ActivePerl%% 5.10 series builds and vice versa.)
  * All other users must have Perl 5.6.0 or above, available from [[http://www.perl.org/get.html| Perl Org]] (Perl 5.7.3 or above, if you want Japanese/Korean language support)   * All other users must have Perl 5.6.0 or above, available from [[http://www.perl.org/get.html| Perl Org]] (Perl 5.7.3 or above, if you want Japanese/Korean language support)
Line 46: Line 46:
  - [[http://search.cpan.org/~gbarr/TimeDate/ | TimeDate]]  (on Windows only)   - [[http://search.cpan.org/~gbarr/TimeDate/ | TimeDate]]  (on Windows only)
  - [[http://search.cpan.org/~mkutter/SOAP-Lite/ | SOAP::Lite]] (if you want to use XMLRPC)   - [[http://search.cpan.org/~mkutter/SOAP-Lite/ | SOAP::Lite]] (if you want to use XMLRPC)
 +  - [[http://search.cpan.org/~phred/XMLRPC-Lite/ | XMLRPC::Lite]] (if you want to use XMLRPC on Windows)
  - [[http://search.cpan.org/~tate/File-Glob-Windows/ | File::Glob::Windows]] (if you want Japanese language support on Windows)   - [[http://search.cpan.org/~tate/File-Glob-Windows/ | File::Glob::Windows]] (if you want Japanese language support on Windows)
 +  - [[http://search.cpan.org/~robertmay/Win32-GUI/ | Win32::GUI]] (POPFile 1.1.0 or later on Windows only (which is used for Tray icon support) )
If you want to use SSL you'll also need OpenSSL (http://www.openssl.org/). If you want to use SSL you'll also need OpenSSL (http://www.openssl.org/).
 
howtos/allplatformsrequireperl.1247614278.txt.gz · Last modified: 2009/07/15 01:31 by amatubu

Should you find anything in the documentation that is incomplete, unclear, outdated or just plain wrong, please let us know and leave a note in the Documentation Forum.

Recent changes RSS feed Donate Driven by DokuWiki
The content of this wiki is protected by the GNU Fee Documentation License