Ticket #207 (assigned defect)

Opened 2 years ago

Last modified 2 years ago

Microsoft email accounts (*.live.com) can't use POPFile (1.1.3)

Reported by: randyored Assigned to: brian (accepted)
Priority: very high Milestone:
Component: POP3 proxy Version: 1.1.3
Severity: critical Keywords:
Cc:

Description

Not sure this is POPfile's issue. I think MS changed something.

I have always had the occasional error with the 3 MS email accounts, Outlook 2010 and POPfile. But, in the last week or so, it has gone from the occasional error, to 100% failures.

Here is the actual error (names changed to protect the... ME!): Task 'MSN-Randyored - Receiving' reported error (0x800CCC91) : 'Your e-mail server rejected your user name. Verify your user name for this account in Account Settings. The server responded: -ERR can't connect to pop3.live.com:995'

If I remove all the "POPFile" configurations from the Outlook settings (going raw - straight to MS with no POPfile) the 3 accounts logons work 100% of the time.

I think MS has changed something that broke SSL on MS accounts. I have 2 other accounts that use SSL and they continue to work fine with POPFile.

Can this be checked out?

Thanks, RandyO

Change History

09/29/15 16:39:59 changed by thoikix

I am having the same issue with a couple of Hotmail accounts (which now use Outlook.com). I tend to use a POP3 connection to access these two accounts, using Thunderbird as my email client, but also using PopMan? for easy notification of new emails, so I seldom log in to them. Both Thunderbird and PopMan? are configured to access my accounts via POPFile, however in the last couple of weeks, they have regularly failed to access the two Hotmail accounts.

These are the messages I found in the POPFile log:

2015/9/29 15:13:47 4932: pop3: 529: Attempting to connect to SSL server at pop3.live.com:995 2015/9/29 15:13:48 4932: pop3: 626: IO::Socket::INET or IO::Socket::SSL gets an error: IO::Socket::SSL: SSL connect attempt failed with unknown errorerror:1411809D:SSL routines:SSL_CHECK_SERVERHELLO_TLSEXT:tls invalid ecpointformat list

I reconfigured PopMan? to access the two Hotmail accounts directly, rather than via PopFile?, and I was able to access both Hotmail accounts. Like RandyO, I suspect the failure is caused by something Micrsoft has changed at their end, which is now preventing POPFile from functioning correctly., and the change is definitely recent (about 2 weeks ago, I would estimate). Could it be related to the fact that Microsoft now refer to there email accounts as "Microsoft accounts" and functionality they may have introduced to support those accounts?

09/29/15 20:21:31 changed by brian

  • status changed from new to assigned.
  • owner changed from admin to brian.

The problem is really that POPFile 1.1.3 does not use an up-to-date version of OpenSSL.

An SSL updater has been produced as a temporary fix until POPFile 1.1.4 is released:

http://getpopfile.org/downloads/updateSSL-mk2-for-POPFile-1.1.3.zip

This SSL updater solved the problem reported by randyored (see message:2105)