Differences

This shows you the differences between two versions of the page.

devel:sslsupport [2011/06/04 00:12]
xuesheng Highlight the fact that this page does not apply to POPFile 1.1.2 or later releases
devel:sslsupport [2011/09/07 16:02] (current)
xuesheng Oops! The current release is NOT v1.1.1
Line 1: Line 1:
====== SSL Support for the Windows version of POPFile ====== ====== SSL Support for the Windows version of POPFile ======
-^ This page only applies to the current POPFile 1.1.1 release and the earlier releases which offer support for SSL connections to mail servers. POPFile 1.1.2 (or later) uses improved SSL support which is built-in to the installer and does not involve any internet access during installation. ^+^ This page only applies to the old POPFile 1.1.1 release and the earlier releases which offer support for SSL connections to mail servers ^
-The SSL support for the Windows version is being upgraded for the next release (POPFile 1.1.2, no release date has been announced yet).+^ POPFile 1.1.2 (or later) uses improved SSL support which is built-in to the installer and does not involve any internet access during installation ^
-A completely new SSL support package is being used which is more up-to-date and smaller than the support packages used by earlier releases of POPFile. The Windows installer will include all of the neceassry files and install them by default. This means the installer will no longer download (and possibly patch) the files during the installation. As a result the installer code has been simplified and made easier to maintain.+For POPFile 1.1.2 (released 21 August 2011) the SSL support for the Windows version was upgraded to use a completely new SSL support package which is more up-to-date and smaller than the support packages used by earlier releases of POPFile. The Windows installer now includes all of the neceassry files and installs them by default. This means the installer will no longer download (and possibly patch) the files during the installation. As a result the installer code has been simplified and made easier to maintain.
===== Why are SSL patches sometimes required? ===== ===== Why are SSL patches sometimes required? =====
Line 323: Line 323:
  * "SSL Support Files Status" information correct as of 18 September 2008   * "SSL Support Files Status" information correct as of 18 September 2008
-  * On 22 June 2005 the University of Winnipeg's SSL files were updated to work with ActivePerl 5.8.7 Build 813 (the then current version of ActivePerl). These changes made the SSL files incompatible with the Windows versions of POPFile 0.22.0, 0.22.1 and 0.22.2 since these releases use older versions of perl58.dll which lack some of the features required by the new SSL Support files. This binary incompatibility prompted the release of POPFile 0.22.3.+  * On 22 June 2005 the University of Winnipeg's SSL files were updated to work with %%ActivePerl%% 5.8.7 Build 813 (the then current version of %%ActivePerl%%). These changes made the SSL files incompatible with the Windows versions of POPFile 0.22.0, 0.22.1 and 0.22.2 since these releases use older versions of perl58.dll which lack some of the features required by the new SSL Support files. This binary incompatibility prompted the release of POPFile 0.22.3.
 
devel/sslsupport.1307139122.txt.gz · Last modified: 2011/06/04 00:12 by xuesheng

Should you find anything in the documentation that is incomplete, unclear, outdated or just plain wrong, please let us know and leave a note in the Documentation Forum.

Recent changes RSS feed Donate Driven by DokuWiki
The content of this wiki is protected by the GNU Fee Documentation License