Mozilla / Netscape / Thunderbird Configuration

This document describes how to make Mozilla / Netscape / Thunderbird Mail work with POPFile. Since they are all based on Mozilla they are very similar and one set of instructions should work. This How To explains how to change your settings to use POPFile as a proxy, how to set up filtering rules based on POPFile's classification, and how to enable a hyperlink to POPFile's single message view. It is assumed that both the mail client and POPFile are installed and running and that their basic concepts and terminology are understood.

Configuring Mozilla / Netscape / Thunderbird for POPFile

  1. Select the Edit→Mail & Newsgroups Account Settings… menu option to bring up the settings dialog. If using Thunderbird this dialog is under Tools→Account Settings….
  2. Select the account you wish to use POPFile with from the options on the left. Make a note of the name, it may be overwritten automaticly when we change other settings. You may use POPFile with all your POP email accounts but each must be setup seperately.
  3. For that account select Server Settings.
  4. Now in the box labled Server Name your ISP's POP email server is listed. Make a note of that because it will be needed again. Then replace it with 127.0.0.1
  5. In the User Name box, add your original POP server (the one we just replaced) followed by a colon : to the front of the username that is already in the box, e.g, if User Name was myname and the original POP server was pop.myisp.net, then the box should contain pop.myisp.net:myname and press OK.
  6. With Thunderbird you will then be warned that you may need to change your email address. Press OK.
  7. If the name of your account was changed go back to Account Settings and change the Account Name back.

Making Mozilla / Netscape / Thunderbird filter mail based on POPFile's categorization

  1. Go to the POPFile Control Center in your web browser (http://127.0.0.1:8080).
  2. Switch to the Buckets tab.
  3. Make sure that Subject Header Modification is switched to Off for each bucket you have created.
  4. Make sure that X-Text-Classification Header is switched to On for each bucket you have created.
  5. Back in Mozilla Mail you need to setup folders to move the filtered messages to. Right click on Inbox on the left pane and select New Folder…. Type in the name of one your buckets and press OK. Repeat this for each bucket that you want to be put in a folder instead of your main inbox.
  6. Select Tools→Message Filters… to bring up the Message Filters dialog.
  7. Click New.
  8. In the Filter name box at the top give the filter a name after one of your buckets. You will set up a filter for each bucket you don't want to be in your inbox.
  9. In the next text box area click on the dropdown box that says Subject and select Customize…. This will let you add a custom header. In this dialog type X-Text-Classification, press Add, then OK. If you already added the header, you can skip this step.
  10. Click on the Subject drop down box again and select the X-Text-Classification option you just added.
  11. Click the next drop down box and change it from Contains to Is.
  12. In the third box type in the name of the bucket you are setting this filter up for exactly like you created it in POPFile.
  13. In the lower part of the window, set the drop-down to “Move message to ” and choose the folder from the drop-down next to this.
  14. Click OK.Screenshot of the Thunderbird filtering rules window
  15. Repeat steps 7 through 14 for each bucket.
  16. Close the Message Filter Dialog and you're done.

See Also:

 
howtos/mozilla_netscape.txt · Last modified: 2009/02/11 15:22 by xuesheng

Should you find anything in the documentation that is incomplete, unclear, outdated or just plain wrong, please let us know and leave a note in the Documentation Forum.

Recent changes RSS feed Donate Driven by DokuWiki
The content of this wiki is protected by the GNU Fee Documentation License